ПЕРЕДМОВА

Електронне видання "Словники України" – 3.0 призначене для надання користувачам лексикографічної інформації про слова української мови. Ця система, як і попередня, складається з п'яти словникових підсистем-модулів – словозміни, транскрипції, синонімії, антонімії та фразеології – виправлених та розширених.

Основу генерального реєстру (понад 252 тис. слів) системи "Словники України" – 3.0 складає реєстр "Орфографічного словника української мови", 5-е видання (К.: Довіра, 2005), який практично повністю відтворено й значно розширено.

Модуль "Словозміна" створено на основі розробленої в Інституті мовно-інформаційних досліджень НАН України словозмінної класифікації української лексики, в якій виділено за певними формальними ознаками понад 2000 парадигматичних класів для всіх відмінюваних повнозначних частин мови. Завдяки вказаній класифікації й розробленій процедурі парадигматизації побудовано повний перелік усіх граматичних форм для всіх лексичних одиниць, наведених у реєстрі. Це забезпечило візуалізацію усіх словоформ в усіх граматичних значеннях. Загальна кількість словоформ для понад 252 тис. одиниць реєстру дорівнює близько 4 млн. У модулі "Словозміна" користувач, вибравши в реєстрі будь-яке слово, автоматично одержує в правому вікні екрану таблицю всіх словоформ для вибраної реєстрової одиниці з поданням їх граматичних параметрів.

Модуль "Транскрипція" забезпечує автоматизоване виведення за допомогою транскрипційних знаків інформації про артикуляцію усіх словоформ української лексики згідно із сучасною літературною вимовою. В основу модуля покладено інформацію, що міститься в "Орфоепічному словнику української мови" в 2-х томах, який вийшов у серії "Словники України" (том 1 – К.: Довіра, 2001, том 2 – К.: Довіра, 2003), а також класифікацію типів дистрибуції наголосів в українських словозмінних парадигмах, розроблену в Інституті мовно-інформаційних досліджень НАН України.

Модуль "Синонімія" з достатньою повнотою подає синонімічне багатство української мови; він створений на основі "Словника синонімів української мови" у 2-х томах, який було випущено в серії "Словники України" (К.: Наукова думка, 1999-2000). Цей модуль містить синонімічні ряди (близько 9200), ядром кожного з яких виступає домінанта – лексична одиниця, що має найзагальніші для цього ряду семантичні особливості. Члени синонімічних рядів супроводжуються семантичними, граматичними та стилістичними характеристиками. Уживання синонімів ілюструється типовими для них контекстами – цитатним матеріалом із художньої, публіцистичної, наукової та іншої літератури або словосполученнями.

Основна частина модуля "Антонімія" – словник антонімів, в якому подано 253 словникові статті. За змістом він відповідає "Словникові антонімів української мови", який вийшов в серії "Словники України" (К.: Довіра, 1999). Загалом у цьому модулі представлено близько 2000 компонентів антонімічних пар.

Модуль "Фразеологія" містить близько 56 тис. фразеологічних одиниць, які вживаються в сучасному українському мовленні. Фразеологізми є основою національного обличчя кожної мови; в них яскраво виявляється специфічний національний колорит, особливості образного народного мислення, власне національне сприйняття "мовної картини світу", віддзеркалення характерних особливостей культури і побуту, народних звичаїв, символіки, історичного минулого. Основою цього модуля послужили "Фразеологічний словник української мови" у 2-х книгах (К.: Наукова думка, 1993; друге видання - К.: Наукова думка, 1999), а також новий "Словник фразеологізмів української мови", що вийшов у серії "Словники України" (К.: Наукова думка, 2003), де найповніше відображено загальновживану фразеологію української мови і дано її всебічну лексикографічну характеристику.


Інтегрована лексикографічна система (ІЛС) „Словники України” 3

КОРИСТУВАННЯ ІЛС „СЛОВНИКИ УКРАЇНИ” 3.0

Електронне видання "Словники України" – 3.0 призначене для надання користувачам лексикографічної інформації про слова української мови. Система складається з п'яти словникових підсистем-модулів (функцій) – словозміни, транскрипції, синонімії, фразеології та антонімії.

Наберіть слово у стрічці пошуку та натисніть <Enter> для отримання інформації про введене слово.

Рис. Головне вікно ІЛС „Словники України” (в інтегрованому режимі)

ІЛС „Словники України” може працювати в інтегрованому режимі, коли біля кожного слова зліва знаходяться літери, що вказують, які функції, окрім словозміни та орфоепії, релевантні для обраного слова (С – синонімія, Ф – фразеологія, А – антонімія), або у режимі окремих словників (словника синонімів, фразеології або антонімів). Режим роботи системи можна обрати у меню Словники.

Рис. Вибір режиму роботи ІЛС „Словники України”.

Вибір функції словозміни, транскрипції, синонімії, фразеології або антонімії в інтегрованому режимі ІЛС „Словники України”.

Рис. ІЛС „Словники України” в інтегрованому режимі, ввімкнуто функцію транскрипції.

Рис. ІЛС „Словники України” в інтегрованому режимі, ввімкнуто функцію синонімії.

Призначення кнопок на панелі інструментів:

зберегти словникову статтю;

роздрукувати словникову статтю;

налаштувати ІЛС „Словники України”;

розташувати вікно ІЛС „Словники України” звичайним способом або поверх інших вікон;

перехід на попередню/наступну словникову статтю;

інформація про ІЛС „Словники України”;

пошук серед фразеологізмів (у підсистемі фразеології).

Рис. ІЛС „Словники України” в режимі словника фразеології.

Рис. ІЛС „Словники України” в інтегрованому режимі, ввімкнуто функцію антонімії.

У системі "Словники України" проведено індексацію словникових статей, що містяться в модулях "Синонімія", "Фразеологія", "Антонімія". Регулярно не індексувалися лише невідмінювані неповнозначні частини мови, оказіоналізми, деякі діалектизми та рідковживані слова, деякі власні назви тощо. Подвійне натискування маніпулятором "миша" на будь-якому слові у правому (інформаційному) вікні програми забезпечує вибір його вихідної форми та автоматичний перехід до цього слова у реєстрі.

Система "Словники України" надає можливість потрапляти з будь-якого вікна (MS Word, MS Access, MS Excel, Internet Explorer тощо) у реєстр системи "Словники України" і отримувати інформацію про обране слово. Для цього користувачеві необхідно виділити слово у тексті і натиснути комбінацію клавіш Ctrl–C–C (клавіша Ctrl при цьому не відпускається), після чого, якщо слово є в словнику, система активізує "Словники України" і виводить на екран довідкову інформацію про вибране слова (програма "Словники України" повинна бути завантаженою).

Для зручності одночасної роботи ІЛС „Словники України” із текстом зовнішньої програми можна зробити вікно системи прозорим та/або розташованим поверх інших вікон. Розташування та рівень прозорості можна змінити у меню Вигляд або через панель інструментів – [image] (настроювання системи) , [image] [image] (розташування вікна системи звичайним способом або поверх інших вікон).

Вибір пункту меню Вигляд > Настроювання дозволяє налаштувати розмір, назву шрифту списку слів та параметри словникової статті, а також встановити рівень прозорості вікон програми.

Рис. Настроювання ІЛС „Словники України”


Про проект

”СЛОВНИКИ УКРАЇНИ” – 3.0

Випуск здійснено відповідно до Указу
Президента України від 7 серпня 1999 року
"Про розвиток національної словникової бази"

Мінімальні системні вимоги:

  • Апаратні - Персональний комп'ютер на базі
    процесора Intel Pentium-II/300, 64Mb RAM, CD-ROM,
    60 Mb вільного дискового простору.
  • Програмне забезпечення - .NET Framework 2.0.

Автори висловлюють щиру подяку укладачам словників серії "Словники України", які відіграли роль традиційних прототипів до окремих функцій інтегрованої лексикографічної системи. Автори щиро дякують працівникам і аспірантам Інституту мовно-інформаційних досліджень НАН України, які взяли активну участь у верифікації та індексації лексикографічних баз даних, що увійшли до складу інтегрованої лексикографічної системи "Словники України".

Ваші відгуки та пропозиції просимо надсилати на адресу:
Інститут мовно-інформаційних досліджень НАН України, вул.Володимирська, 54, Київ-30, 01601.
Тел./факс: +380-44-525-8165.
http://ulif.org.ua; e-mail: ulif@ulif.org.ua

© В.А. Широков, О.Г. Рабулець, І.В. Шевченко, О.М. Костишин, К.М. Якименко, 2001-2006